Bitcoin86.com

Bitcoin-Qt 用户需要升级客户端

比特币基金会项目的比特币客户端代码维护者Gavin Andresen今天在bitcointalk上发布了Bitcoin-Qt(中本聪客户端)的新版本0.8.4 。Gavin Andresen称旧的Bitcoin-Qt客户端存在严重的问题,使用中本聪客户端的用户需要尽快升级到0.8.4版。



编者提示
使用Bitcoin-Qt的小伙伴们如果没有在服务器上面运行Bitcoind的话,完全不用着急升级客户端。你们被攻击的概率很小。在升级前,一定要做好钱包文件的备份和保管工作,否则一旦忙中出错就不划算了。

请务必确认在Bitcoin-Qt关闭后备份wallet.dat而不是在关闭前,否则对于一些正在交易的玩家可能由于Bitcoin-Qt的地址找零机制而丢失比特币。或者在升级前将Bitcoin-Qt钱包文件导入Blockchain在线钱包中,以确保其安全性。

如何将Bitcoin-Qt钱包导入Blockchain在线钱包?

如何升级
如果你现在正在使用旧的中本聪客户端,请先将其完全关闭,并保存好钱包文件(wallet.dat)。

在保存完钱包后,下载并运行新版本Bitcoin-Qt 0.8.4即可。

旧版本的问题
在旧版中没有布隆过滤器的设置,从而会造成 division-by-zero 的错误,从而使Bitcoin-Qt和守护进程Bitcoind突然崩溃。另外,新版本可以有效地防止运行Bitcoind的服务被拒绝服务攻击或者通过 RPC协议进行Brute Force。

下载升级程序
现在升级版的Bitcoin-Qt 0.8.4可以在sourceforge下载了。

下载Bitcoin-Qt 0.8.4 请点击这里

报告使用中出现的Bug 请点击这里

查看Bitcointalk论坛原帖 请点击这里

转自比巴克

地址:http://p2pbucks.com/?p=7161

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

分享: